Flash Player Support

***
Mozilla has recently blocked a certain vulnerable version of Flash player.

see: https://addons.mozilla.org/en-US/firefox/blocked/ for more details.
We suggest upgrading your flash player to the latest version to resolve this issue.

***


Symptoms
The following message appears:
“Flash Player version is Incompatible.”

Cause of problem
Invoke Solutions sessions require a Flash Player plug-in version 9.0 or later for the browser. The problem has occurred either because you do not have Flash Player installed, or the version that is installed is not compatible with Invoke sessions.

Solution
You need to install a supported version of Flash Player. Follow the instructions below.

If you do not have Flash Player or if you do not have the required Flash Player version, you cannot see the Flash clip above. If indeed you do not see the Flash clip, click in it as instructed and follow the installation steps.

When the installation is complete, you should be able to see the clip above. Return to the Invoke session page and click Retry.

If you still cannot see the Flash clip, go to http://get.adobe.com/flashplayer/ for further help.

Can’t find answers?
Contact Support